Windows 7 64bit upgrade and Intel Storage manager issues




Windows 7 Default Desktop

Originally uploaded by nopattern

I just upgraded my 3 year old Dell Dimension E520 to Windows 7. I did a fresh install just to make sure there wasn’t any legacy junk from Vista hanging around. So far I’m very happy with Windows 7 so far! Its certainly faster, networking capabilities is certainly better and easier! It also works super well with my Xbox360 perfectly now!

I originally purchased my Dell with Windows XP 32bit, and later did an upgrade to Vista 32-bit. I had so many issues with Vista 32bit. The machine certainly got better with Sp1 came out, but the biggest problems I had to deal with was the Cisco VPN client did not work on machines that were upgraded to Vista. This made working at home an issue. The Cisco VPN client only worked on a fresh install of Windows Vista 32bit, and had no support for Windows VIsta 64bit. After a few months of struggling with various problems I wiped my machine and did a fresh install of Windows Vista 32bit. It was relatively problem and crash free since doing the fresh install, but I’ve consistently had strange network issues with Vista.

Some strangeness I had to deal with using Vista 32bit was my machine was invisible on the network even with the firewall disabled. The vista machine could access other machines with no issue, but other devices could not reach the Vista box using various methods (ping/netbios/CIFS/etc). I knew the local IP of the Dell, and it was basically invisible to the rest of the network sometimes till I pinged the IP address of the Vista box. Yes that sounds crazy..but that was the behavior. Trying to use the Xbox360 with Vista was painful due to these network issues.

Now I’m using Windows 7, and I have zero networking issues! All machines can see each other on the network including the Xbox360.

I’ve been using my windows 7 box for a few weeks now and I noticed my box would freeze up occasionally. I checked the event log and saw a few hundred of these messages:

Log Name: System
Source: iaStorV
Date: 11/6/2009 5:08:22 PM
Event ID: 9
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: VADER
Description:
The device, \Device\Ide\iaStor0, did not respond within the timeout period.

I checked around the internet and noticed that other Dell owners were having the same issue when they upgrade to a 64bit Vista or Windows 7. It appears Microsoft is using the wrong driver for the Intel Storage Manager to run under a 64 bit OS

http://www.pdsys.org/blog/post/2007/04/10/Dell-and-Intel-screw-up-big-time-iaStor-and-Windows-Vista.aspx

this is the latest Intel driver to fix the issue:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProductID=2101&DwnldID=17882&strOSs=44&OSFullName=Windows*

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.